SourceForge.net Logo

Java Service Launcher (for Windows) JSL 0.99q - January 2017

Download here or contact the author at  Michael@Roeschter.com

Which software is needed to run the JSL?

Windows 8,7 Vista, Win 2008, Win 2003, Win2000 or NT4. Both JDK or JRE are fine. 32bit and 64bit OS versions as well as 32bit and 64bit JVMs JRE/JDK versions 1.2.x, 1.3.x, 1.4.x., 1.5.x, 1.6.x, 1.7.x, 1.8.x
You need a 64bit OS to run 64bit JSL, but you can also run the 32bit version on a 64bit OS. The 64bit JSL starts the 64bit JVM and the 32bit JSl run the 32bit JVM.
When running the plain jsl.exe, which is a bit smaller and dynamically linked you will need a few Microsfot Visual C libraries, which most likely are already on your system. If you see problems, try the statically linked executable which has no such dependencies.
The JDK might be installed or just copied to the machine. If its properly installed the JSL will find it automatically through the resgitry entry. If not, or if you do not like this behaviour, just set the jrepath option in the configuration file. The JSL needs no setup and can simply be copied anywhere. Please note the limitations concerning running in a network as explained in the FAQ.